const regex = /(score.*\d\d|score.*\d)/mi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(score.*\\d\\d|score.*\\d)', 'mi')
const str = `games >= 2 AND score between 1 and 10 and Pais = 2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}