re = /(score.*\d\d|score.*\d)/mi
str = 'games >= 2 AND score between 1 and 10 and Pais = 2
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end