$re = '/(score.*\d\d|score.*\d)/mi';
$str = 'games >= 2 AND score between 1 and 10 and Pais = 2
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);