#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/\^?(?:\[(A-Z|a-z|0-9)(?!\1)(A-Z|a-z|0-9)(?!\2)(A-Z|a-z|0-9)\]|\[\^\\W_])[+*?]?\$?\/"
Local $sString = "/[A-Za-z0-9]/" & @CRLF & _
"/[A-Za-z0-9]+/" & @CRLF & _
"/[A-Za-z0-9]*/" & @CRLF & _
"/^[A-Za-z0-9]/" & @CRLF & _
"/[A-Za-z0-9]$/" & @CRLF & _
"/^[A-Za-z0-9]+$/" & @CRLF & _
"/^[A-Za-z0-9]*$/" & @CRLF & _
"/^[A-Za-z0-9]?$/" & @CRLF & _
"/^[^\W_]+$/" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")