$re = '/^\/\^?(?:\[(A-Z|a-z|0-9)(?!\1)(A-Z|a-z|0-9)(?!\2)(A-Z|a-z|0-9)\]|\[\^\\\\W_])[+*?]?\$?\//m';
$str = '/[A-Za-z0-9]/
/[A-Za-z0-9]+/
/[A-Za-z0-9]*/
/^[A-Za-z0-9]/
/[A-Za-z0-9]$/
/^[A-Za-z0-9]+$/
/^[A-Za-z0-9]*$/
/^[A-Za-z0-9]?$/
/^[^\\W_]+$/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);