import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/\\^?(?:\\[(A-Z|a-z|0-9)(?!\\1)(A-Z|a-z|0-9)(?!\\2)(A-Z|a-z|0-9)\\]|\\[\\^\\\\W_])[+*?]?\\$?\\/";
final String string = "/[A-Za-z0-9]/\n"
+ "/[A-Za-z0-9]+/\n"
+ "/[A-Za-z0-9]*/\n"
+ "/^[A-Za-z0-9]/\n"
+ "/[A-Za-z0-9]$/\n"
+ "/^[A-Za-z0-9]+$/\n"
+ "/^[A-Za-z0-9]*$/\n"
+ "/^[A-Za-z0-9]?$/\n"
+ "/^[^\\W_]+$/\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}