re = /^\/\^?(?:\[(A-Z|a-z|0-9)(?!\1)(A-Z|a-z|0-9)(?!\2)(A-Z|a-z|0-9)\]|\[\^\\W_])[+*?]?\$?\//m
str = '/[A-Za-z0-9]/
/[A-Za-z0-9]+/
/[A-Za-z0-9]*/
/^[A-Za-z0-9]/
/[A-Za-z0-9]$/
/^[A-Za-z0-9]+$/
/^[A-Za-z0-9]*$/
/^[A-Za-z0-9]?$/
/^[^\\W_]+$/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end