#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^(?!.*([._-])[._-]{1,})[A-Za-z0-9][A-Za-z0-9._-]{0,33}[A-Za-z0-9]$)|(?:^[A-Za-z0-9]{1,2}$)"
Local $sString = "OKs" & @CRLF & _
"A" & @CRLF & _
"AB" & @CRLF & _
"1" & @CRLF & _
"2022" & @CRLF & _
"ABC123" & @CRLF & _
"ABC-123" & @CRLF & _
"ABC-DE-123" & @CRLF & _
"ABC-DE.123" & @CRLF & _
"NOT_OK!" & @CRLF & _
"-" & @CRLF & _
"A-" & @CRLF & _
"-A" & @CRLF & _
"ABC--123" & @CRLF & _
"ABC.-123" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")