use strict;
my $str = 'OKs
A
AB
1
2022
ABC123
ABC-123
ABC-DE-123
ABC-DE.123
NOT_OK!
-
A-
-A
ABC--123
ABC.-123
';
my $regex = qr/(?:^(?!.*([._-])[._-]{1,})[A-Za-z0-9][A-Za-z0-9._-]{0,33}[A-Za-z0-9]$)|(?:^[A-Za-z0-9]{1,2}$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}