import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^(?!.*([._-])[._-]{1,})[A-Za-z0-9][A-Za-z0-9._-]{0,33}[A-Za-z0-9]$)|(?:^[A-Za-z0-9]{1,2}$)";
final String string = "OKs\n"
+ "A\n"
+ "AB\n"
+ "1\n"
+ "2022\n"
+ "ABC123\n"
+ "ABC-123\n"
+ "ABC-DE-123\n"
+ "ABC-DE.123\n"
+ "NOT_OK!\n"
+ "-\n"
+ "A-\n"
+ "-A\n"
+ "ABC--123\n"
+ "ABC.-123\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}