re = /(?:^(?!.*([._-])[._-]{1,})[A-Za-z0-9][A-Za-z0-9._-]{0,33}[A-Za-z0-9]$)|(?:^[A-Za-z0-9]{1,2}$)/m
str = 'OKs
A
AB
1
2022
ABC123
ABC-123
ABC-DE-123
ABC-DE.123
NOT_OK!
-
A-
-A
ABC--123
ABC.-123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end