using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Can I have(?:(?!\s*please).)*";
string input = @"RANDOMNUMBERS Can I have some milk please or RANDOMNUMBERS Can I have some milk
RANDOMNUMBERS Can I have more toast please
RANDOMNUMBERS Can I have more toast";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}