import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Can I have(?:(?!\\s*please).)*";
final String string = "RANDOMNUMBERS Can I have some milk please or RANDOMNUMBERS Can I have some milk\n"
+ "RANDOMNUMBERS Can I have more toast please\n"
+ "RANDOMNUMBERS Can I have more toast";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}