re = /Can I have(?:(?!\s*please).)*/m
str = 'RANDOMNUMBERS Can I have some milk please or RANDOMNUMBERS Can I have some milk
RANDOMNUMBERS Can I have more toast please
RANDOMNUMBERS Can I have more toast'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end