package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-rule\s*"([^"\\]*(?:\\.[^"\\]*)*)"`)
var str = `add lb vserver VS_ssl_443_testapps SSL 0.0.0.0 0 -persistenceType RULE -timeout 30 -rule "HTTP.REQ.COOKIE.VALUE(\"JSESSIONID\")" -resRule "HTTP.RES.SET_COOKIE.COOKIE(\"JSESSIONID\").VALUE(\"JSESSIONID\")" -cltTimeout 600 -td 1
add lb vserver VS_ssl_8443_testapps SSL 0.0.0.0 0 -persistenceType RULE -timeout 30 -rule "HTTP.REQ.COOKIE.VALUE(\"jsessionid\") ALT HTTP.REQ.URL.BEFORE_STR(\"?\").AFTER_STR(\";jsessionid=\") ALT HTTP.REQ.URL.AFTER_STR(\";jsessionid=\")" -resRul
add lb vserver VS_ssl_8443_testapps SSL 0.0.0.0 0 -persistenceType RULE -timeout 30 -rule "HTTP.REQ.COOKIE.VALUE(\"jsessionid\") ALT HTTP.REQ.URL.BEFORE_STR(\"?\").AFTER_STR(\";jsessionid=\") ALT HTTP.REQ.URL.AFTER_STR(\";jsessionid=\")" -resRule "HTTP.REQ.COOKIE.VALUE(\"jsessionid\") ALT HTTP.REQ.URL.BEFORE_STR(\"?\").AFTER_STR(\";jsessionid=\") ALT HTTP.REQ.URL.AFTER_STR(\";jsessionid=\")"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}