const regex = new RegExp('-rule\\s*"([^"\\\\]*(?:\\\\.[^"\\\\]*)*)"', 'gm')
const str = `add lb vserver VS_ssl_443_testapps SSL 0.0.0.0 0 -persistenceType RULE -timeout 30 -rule "HTTP.REQ.COOKIE.VALUE(\\"JSESSIONID\\")" -resRule "HTTP.RES.SET_COOKIE.COOKIE(\\"JSESSIONID\\").VALUE(\\"JSESSIONID\\")" -cltTimeout 600 -td 1
add lb vserver VS_ssl_8443_testapps SSL 0.0.0.0 0 -persistenceType RULE -timeout 30 -rule "HTTP.REQ.COOKIE.VALUE(\\"jsessionid\\") ALT HTTP.REQ.URL.BEFORE_STR(\\"?\\").AFTER_STR(\\";jsessionid=\\") ALT HTTP.REQ.URL.AFTER_STR(\\";jsessionid=\\")" -resRul
add lb vserver VS_ssl_8443_testapps SSL 0.0.0.0 0 -persistenceType RULE -timeout 30 -rule "HTTP.REQ.COOKIE.VALUE(\\"jsessionid\\") ALT HTTP.REQ.URL.BEFORE_STR(\\"?\\").AFTER_STR(\\";jsessionid=\\") ALT HTTP.REQ.URL.AFTER_STR(\\";jsessionid=\\")" -resRule "HTTP.REQ.COOKIE.VALUE(\\"jsessionid\\") ALT HTTP.REQ.URL.BEFORE_STR(\\"?\\").AFTER_STR(\\";jsessionid=\\") ALT HTTP.REQ.URL.AFTER_STR(\\";jsessionid=\\")"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}