// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)-rule\s*"([^"\\]*(?:\\.[^"\\]*)*)""#).unwrap();
let string = "add lb vserver VS_ssl_443_testapps SSL 0.0.0.0 0 -persistenceType RULE -timeout 30 -rule \"HTTP.REQ.COOKIE.VALUE(\\\"JSESSIONID\\\")\" -resRule \"HTTP.RES.SET_COOKIE.COOKIE(\\\"JSESSIONID\\\").VALUE(\\\"JSESSIONID\\\")\" -cltTimeout 600 -td 1
add lb vserver VS_ssl_8443_testapps SSL 0.0.0.0 0 -persistenceType RULE -timeout 30 -rule \"HTTP.REQ.COOKIE.VALUE(\\\"jsessionid\\\") ALT HTTP.REQ.URL.BEFORE_STR(\\\"?\\\").AFTER_STR(\\\";jsessionid=\\\") ALT HTTP.REQ.URL.AFTER_STR(\\\";jsessionid=\\\")\" -resRul
add lb vserver VS_ssl_8443_testapps SSL 0.0.0.0 0 -persistenceType RULE -timeout 30 -rule \"HTTP.REQ.COOKIE.VALUE(\\\"jsessionid\\\") ALT HTTP.REQ.URL.BEFORE_STR(\\\"?\\\").AFTER_STR(\\\";jsessionid=\\\") ALT HTTP.REQ.URL.AFTER_STR(\\\";jsessionid=\\\")\" -resRule \"HTTP.REQ.COOKIE.VALUE(\\\"jsessionid\\\") ALT HTTP.REQ.URL.BEFORE_STR(\\\"?\\\").AFTER_STR(\\\";jsessionid=\\\") ALT HTTP.REQ.URL.AFTER_STR(\\\";jsessionid=\\\")\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}