import re
regex = re.compile(r"-rule\s*\"([^\"\\]*(?:\\.[^\"\\]*)*)\"", flags=re.MULTILINE)
test_str = ("add lb vserver VS_ssl_443_testapps SSL 0.0.0.0 0 -persistenceType RULE -timeout 30 -rule \"HTTP.REQ.COOKIE.VALUE(\\\"JSESSIONID\\\")\" -resRule \"HTTP.RES.SET_COOKIE.COOKIE(\\\"JSESSIONID\\\").VALUE(\\\"JSESSIONID\\\")\" -cltTimeout 600 -td 1\n\n"
"add lb vserver VS_ssl_8443_testapps SSL 0.0.0.0 0 -persistenceType RULE -timeout 30 -rule \"HTTP.REQ.COOKIE.VALUE(\\\"jsessionid\\\") ALT HTTP.REQ.URL.BEFORE_STR(\\\"?\\\").AFTER_STR(\\\";jsessionid=\\\") ALT HTTP.REQ.URL.AFTER_STR(\\\";jsessionid=\\\")\" -resRul\n\n"
"add lb vserver VS_ssl_8443_testapps SSL 0.0.0.0 0 -persistenceType RULE -timeout 30 -rule \"HTTP.REQ.COOKIE.VALUE(\\\"jsessionid\\\") ALT HTTP.REQ.URL.BEFORE_STR(\\\"?\\\").AFTER_STR(\\\";jsessionid=\\\") ALT HTTP.REQ.URL.AFTER_STR(\\\";jsessionid=\\\")\" -resRule \"HTTP.REQ.COOKIE.VALUE(\\\"jsessionid\\\") ALT HTTP.REQ.URL.BEFORE_STR(\\\"?\\\").AFTER_STR(\\\";jsessionid=\\\") ALT HTTP.REQ.URL.AFTER_STR(\\\";jsessionid=\\\")\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")