import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:1[01][0-9]|120|1[7-9]|[2-9][0-9])$";
final String string = "1\n"
+ "16\n"
+ "17\n"
+ "99\n"
+ "100\n"
+ "111\n"
+ "120\n"
+ "121\n"
+ "999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}