import re
regex = re.compile(r"^(?:1[01][0-9]|120|1[7-9]|[2-9][0-9])$", flags=re.MULTILINE)
test_str = ("1\n"
"16\n"
"17\n"
"99\n"
"100\n"
"111\n"
"120\n"
"121\n"
"999")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")