$re = '/^(?:1[01][0-9]|120|1[7-9]|[2-9][0-9])$/m';
$str = '1
16
17
99
100
111
120
121
999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);