#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\u06cc(?=[\u0600-\u06ff])"
Local $sString = "گیر" & @CRLF & _
"غیبت" & @CRLF & _
"قیمت" & @CRLF & _
"یرغال" & @CRLF & _
"کسی" & @CRLF & _
"کمی" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")