$re = '/\u06cc(?=[\u0600-\u06ff])/';
$str = 'گیر
غیبت
قیمت
یرغال
کسی
کمی
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);