const regex = /\u06cc(?=[\u0600-\u06ff])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\u06cc(?=[\\u0600-\\u06ff])', 'g')
const str = `گیر
غیبت
قیمت
یرغال
کسی
کمی
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}