using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\u06cc(?=[\u0600-\u06ff])";
string input = @"گیر
غیبت
قیمت
یرغال
کسی
کمی
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}