#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?<DATE>\d{1,2}\/\d{1,2}\/\d{2})\s[A-Z0-9]{4}\/\d{7}(?<LE>\s[A-Z]{4}\d{6}\-\d).*(?<LPreis>\s\d+,\d{2})\s+06[\s\S]*?(?<GGF>(?=(Dangerous goods:).\d,\d{2})|)(.|\n)*?(?<SUB>(?=(SUBSIDIES)\s+\d+,\d{2})|)(.|\n)*?(?<ADR>(?=(ADR SURCHARGE CH)\s+\d+,\d{2})|).*)"
Local $sString = "* 19/11/21 SSS2/3000000 AAAA300007-0 028/2 782 4000 690,00 06" & @CRLF & _
"5527315" & @CRLF & _
"Dangerous goods: 150,00" & @CRLF & _
"Additional performances:" & @CRLF & _
"- SUPPL.REDUCTION CH GOVERNMENT SUBSIDIES 5,00" & @CRLF & _
"- ADR SURCHARGE CH 2,00" & @CRLF & _
"" & @CRLF & _
"19/11/21 BBB2/6000000 BBBB200006-0 222/2 715 2620 690,00 06" & @CRLF & _
"5545628" & @CRLF & _
"Additional performances:" & @CRLF & _
"- SUPPL.REDUCTION CH GOVERNMENT SUBSIDIES 150,00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")