$re = '/((?<DATE>\d{1,2}\/\d{1,2}\/\d{2})\s[A-Z0-9]{4}\/\d{7}(?<LE>\s[A-Z]{4}\d{6}\-\d).*(?<LPreis>\s\d+,\d{2})\s+06[\s\S]*?(?<GGF>(?=(Dangerous goods:).\d,\d{2})|)(.|\n)*?(?<SUB>(?=(SUBSIDIES)\s+\d+,\d{2})|)(.|\n)*?(?<ADR>(?=(ADR SURCHARGE CH)\s+\d+,\d{2})|).*)/m';
$str = '* 19/11/21 SSS2/3000000 AAAA300007-0 028/2 782 4000 690,00 06
5527315
Dangerous goods: 150,00
Additional performances:
- SUPPL.REDUCTION CH GOVERNMENT SUBSIDIES 5,00
- ADR SURCHARGE CH 2,00
19/11/21 BBB2/6000000 BBBB200006-0 222/2 715 2620 690,00 06
5545628
Additional performances:
- SUPPL.REDUCTION CH GOVERNMENT SUBSIDIES 150,00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);