# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?<DATE>\d{1,2}\/\d{1,2}\/\d{2})\s[A-Z0-9]{4}\/\d{7}(?<LE>\s[A-Z]{4}\d{6}\-\d).*(?<LPreis>\s\d+,\d{2})\s+06[\s\S]*?(?<GGF>(?=(Dangerous goods:).\d,\d{2})|)(.|\n)*?(?<SUB>(?=(SUBSIDIES)\s+\d+,\d{2})|)(.|\n)*?(?<ADR>(?=(ADR SURCHARGE CH)\s+\d+,\d{2})|).*)"
test_str = ("* 19/11/21 SSS2/3000000 AAAA300007-0 028/2 782 4000 690,00 06\n"
"5527315\n"
"Dangerous goods: 150,00\n"
"Additional performances:\n"
"- SUPPL.REDUCTION CH GOVERNMENT SUBSIDIES 5,00\n"
"- ADR SURCHARGE CH 2,00\n\n"
"19/11/21 BBB2/6000000 BBBB200006-0 222/2 715 2620 690,00 06\n"
"5545628\n"
"Additional performances:\n"
"- SUPPL.REDUCTION CH GOVERNMENT SUBSIDIES 150,00")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.