use strict;
my $str = '* 19/11/21 SSS2/3000000 AAAA300007-0 028/2 782 4000 690,00 06
5527315
Dangerous goods: 150,00
Additional performances:
- SUPPL.REDUCTION CH GOVERNMENT SUBSIDIES 5,00
- ADR SURCHARGE CH 2,00
19/11/21 BBB2/6000000 BBBB200006-0 222/2 715 2620 690,00 06
5545628
Additional performances:
- SUPPL.REDUCTION CH GOVERNMENT SUBSIDIES 150,00';
my $regex = qr/((?<DATE>\d{1,2}\/\d{1,2}\/\d{2})\s[A-Z0-9]{4}\/\d{7}(?<LE>\s[A-Z]{4}\d{6}\-\d).*(?<LPreis>\s\d+,\d{2})\s+06[\s\S]*?(?<GGF>(?=(Dangerous goods:).\d,\d{2})|)(.|\n)*?(?<SUB>(?=(SUBSIDIES)\s+\d+,\d{2})|)(.|\n)*?(?<ADR>(?=(ADR SURCHARGE CH)\s+\d+,\d{2})|).*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}