const regex = new RegExp('(\\+\\d{3})?\\s*(\\d{7,8})', 'gm')
const str = `+372 56887364 +37256887364 +33359835647 56887364 +11 1234567 +327 1 11111111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}