$re = '/(\+\d{3})?\s*(\d{7,8})/m';
$str = '+372 56887364 +37256887364 +33359835647 56887364 +11 1234567 +327 1 11111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);