// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\+\d{3})?\s*(\d{7,8})").unwrap();
let string = "+372 56887364 +37256887364 +33359835647 56887364 +11 1234567 +327 1 11111111";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}