import re
regex = re.compile(r"(\+\d{3})?\s*(\d{7,8})", flags=re.MULTILINE)
test_str = "+372 56887364 +37256887364 +33359835647 56887364 +11 1234567 +327 1 11111111"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")