#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(P(?:[1-9]|1[012])\.S(?:[1-9]|\d{2}|10\d|11[012])\b)"
Local $sString = "DF62.1 P8.S12 P105.H10 RK121.2" & @CRLF & _
"DF57.1 P105.B4 P7.S5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")