// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(P(?:[1-9]|1[012])\.S(?:[1-9]|\d{2}|10\d|11[012])\b)").unwrap();
let string = "DF62.1 P8.S12 P105.H10 RK121.2
DF57.1 P105.B4 P7.S5";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}