package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(P(?:[1-9]|1[012])\.S(?:[1-9]|\d{2}|10\d|11[012])\b)`)
var str = `DF62.1 P8.S12 P105.H10 RK121.2
DF57.1 P105.B4 P7.S5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}