re = /(P(?:[1-9]|1[012])\.S(?:[1-9]|\d{2}|10\d|11[012])\b)/m
str = 'DF62.1 P8.S12 P105.H10 RK121.2
DF57.1 P105.B4 P7.S5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end