#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(-?[\d?]+)([^=\d?])(-?[\d?]+)=(-?[\d?]+)"
Local $sString = "1+1=?" & @CRLF & _
"123*45?=5?088" & @CRLF & _
"-5?*-1=5?" & @CRLF & _
"19--45=5?" & @CRLF & _
"??*??=302?" & @CRLF & _
"?*11=??" & @CRLF & _
"??*1=??" & @CRLF & _
"??+??=??" & @CRLF & _
"?33438-103326=410112"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")