import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(-?[\\d?]+)([^=\\d?])(-?[\\d?]+)=(-?[\\d?]+)";
final String string = "1+1=?\n"
+ "123*45?=5?088\n"
+ "-5?*-1=5?\n"
+ "19--45=5?\n"
+ "??*??=302?\n"
+ "?*11=??\n"
+ "??*1=??\n"
+ "??+??=??\n"
+ "?33438-103326=410112";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}