re = /(-?[\d?]+)([^=\d?])(-?[\d?]+)=(-?[\d?]+)/m
str = '1+1=?
123*45?=5?088
-5?*-1=5?
19--45=5?
??*??=302?
?*11=??
??*1=??
??+??=??
?33438-103326=410112'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end