const regex = /(-?[\d?]+)([^=\d?])(-?[\d?]+)=(-?[\d?]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(-?[\\d?]+)([^=\\d?])(-?[\\d?]+)=(-?[\\d?]+)', 'gm')
const str = `1+1=?
123*45?=5?088
-5?*-1=5?
19--45=5?
??*??=302?
?*11=??
??*1=??
??+??=??
?33438-103326=410112`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}