import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"([^\"]+)\"|(.*) <";
final String string = "peter@pan.com\n"
+ "lucky <jack@pot.com>\n"
+ "\"William Tell\" <billy@tell.com>\n"
+ "\"John Rambo, III\" <johnny@rambo.com>\n"
+ "\"there, might, be, several, commas inside the quotes\" <multiple@commas.com>\n"
+ "\"yes, this is also a valid email address, can you believe\" <yes@this@is@valid.com>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}