import re
regex = re.compile(r"\"([^\"]+)\"|(.*) <", flags=re.IGNORECASE)
test_str = ("peter@pan.com\n"
"lucky <jack@pot.com>\n"
"\"William Tell\" <billy@tell.com>\n"
"\"John Rambo, III\" <johnny@rambo.com>\n"
"\"there, might, be, several, commas inside the quotes\" <multiple@commas.com>\n"
"\"yes, this is also a valid email address, can you believe\" <yes@this@is@valid.com>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")