const regex = /^(\w+)+\s\|{3}\s(\w+)\s\|{3}\s(.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w+)+\\s\\|{3}\\s(\\w+)\\s\\|{3}\\s(.*)', 'g')
const str = `amornratchatchawansawangwong ||| amornratchatchawansawangwong . ||| 0.594819 0.5 0.594819 0.25 ||| 0-0 0-1 ||| 1 1 1 ||| |||`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}