re = /^(\w+)+\s\|{3}\s(\w+)\s\|{3}\s(.*)/
str = 'amornratchatchawansawangwong ||| amornratchatchawansawangwong . ||| 0.594819 0.5 0.594819 0.25 ||| 0-0 0-1 ||| 1 1 1 ||| |||'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end