import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*[-+.'\\w]+@(?!(?:adres|vp)\\.pl\\b)\\w+(?:[-.]\\w+)*\\.(?!co\\s*$)\\w{2,}\\s*$";
final String string = "john@adres.pl\n"
+ "test@test.com\n\n"
+ "35435gd\n"
+ "john@adres.pl\n"
+ "john@gmail.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}