const regex = new RegExp('^\\s*[-+.\\'\\w]+@(?!(?:adres|vp)\\.pl\\b)\\w+(?:[-.]\\w+)*\\.(?!co\\s*$)\\w{2,}\\s*$', 'gm')
const str = `john@adres.pl
test@test.com
35435gd
john@adres.pl
john@gmail.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}