$re = '/^\s*[-+.\'\w]+@(?!(?:adres|vp)\.pl\b)\w+(?:[-.]\w+)*\.(?!co\s*$)\w{2,}\s*$/m';
$str = 'john@adres.pl
test@test.com
35435gd
john@adres.pl
john@gmail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);