re = /^\s*[-+.'\w]+@(?!(?:adres|vp)\.pl\b)\w+(?:[-.]\w+)*\.(?!co\s*$)\w{2,}\s*$/m
str = 'john@adres.pl
test@test.com
35435gd
john@adres.pl
john@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end