#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^|&)(page=)\d+(?=&(?:.*&)?\1)"
Local $sString = "page=2&page=3&page=4" & @CRLF & _
"page=2&page=3" & @CRLF & _
"page=2&foo=bar&page=3" & @CRLF & _
"page=2" & @CRLF & _
"other_parameter=other_value&page=2&another_paramenter=another_value" & @CRLF & _
"other_parameter=other_value&page=2&page=3&page=4&another_paramenter=another_value"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")